Article ID:
K00000243
Last Reviewed:
19 September 2005
Symptoms
When you attempt to start the adTempus service, Windows reports that the service could not be started, or that the service started and stopped immediately.
A review of the adTempus diagnostic logs reveals an error message similar to the following:
Error -2147467259: Unrecognized database format 'C:\Program Files\Arcana Development\adTempus\data\adtempus.mdb'. (source=Microsoft JET Database Engine; native error=-536544438; SQL state=3343)
Cause
This error indicates that the Microsoft Access database used by adTempus has become corrupted.
Resolution
If you have access to a copy of Microsoft Access, you can try to open and repair the adTempus database file (named in the error message cited above). If the repair process succeeds, you should be able to start the adTempus service.
If you do not have Microsoft Access, contact Arcana Development for assistance and we will attempt to recover the database.
If Microsoft Access is unable to repair the database, you will need to restore the database from a backup, as described in article K00000181.
Status
Because the Microsoft Access database is prone to performance and corruption problems, Arcana Development strongly recommends that all customers use a SQL Server or MSDE database instead. For more information, including information on how to convert your existing database, see the Database Conversion topic in the adTempus help.
Note that you must repair or restore your Microsoft Access database before converting to SQL Server if you wish to preserve your existing data.